[606] Plugin crash (lh.json:0)

Plugin specific problems will be solved here.

Moderator: Plugin Moderators

Zpeezy
Settler
Reactions:
Posts: 1
Joined: Sat May 11, 2019 6:31
Plugins: Show

[606] Plugin crash (lh.json:0)

#1

Post by Zpeezy » Sat May 11, 2019 8:26

Hi, I got the following error with a plugin (lh.json:0):

Code: Select all

In /mnt/expand/b809c4c4-cd9c-45d8-a0e3-2b263a003bb4/user/0/info.flowersoft.theotown.theotown/files/plugins/plg_roads_expansion_pack_josh_v1.0.zip/2-lane highway/lh.json:

java.lang.IllegalStateException: When loading "geveecegg": geveecegg is already in use. Use another id or add "override":true to your plugin.
Device: Z835 (ZTE)
Android: 25 (7.1.1)

Thank you in advance. Your friend, Zp

User avatar
Lobby
Developer
Reactions:
Posts: 3331
Joined: Sun Oct 26, 2008 12:34
Plugins: Show
Version: Beta
Phone model: S7 edge

Platform

Re: [606] Plugin crash (lh.json:0)

#2

Post by Lobby » Sat May 11, 2019 14:58

See here.

It means that the given Id was already in use, in other words a plugin with the same id exists in your plugin folder or Theotown.
Solution: There are many causes for this, e.g. downloaded a plugin twice, put both the folder and zip inside the plugin folder etc...
So, the easiest way to solve this is by adding "override":true, or changing the id.
If you're trying to replace a in-game building then you must add "override":true, for it to be overridden.

It also happens if you move have a copy of the TheoTown folder stored on your sd card.
...Have a nice stay

Post Reply Previous topicNext topic

Return to “Problems”